Search This Blog

Tuesday, February 23, 2010

Issues when developing with Visual Studio 2010 RC and SharePoint 2010 Beta 2

Recently, since development with SharePoint 2010 Beta 2 had been going so well; decided to jump into installing Visual Studio 2010 RC.

Followed the common steps:

  • Uninstall Visual Studio 2010 Beta 2
  • Uninstall .Net Framework 4 Extended Beta 2
  • Uninstall .Net Framework 4 Client Profile Beta 2
  • Install .Net Framework 4 RC
  • Install .Net Framework 4 RC Client Profile
  • Install Visual Studio 2010 RC

Immediately assumed that SharePoint 2010 Beta 2 and Visual Studio 2010 RC would get along well and for the most part they did.

While in the IDE was able to perform pretty much all the necessary tasks a developer does:

  • Add and Configure Controls
  • Add References
  • Configure Project Settings
  • Build

The issue would arise when attempting to Debug or Run the application:

Capture 

The error is caused because the Frameworks are not the same, in other words to develop solutions with Visual Studio 2010 RC and SharePoint 2010 you must have also SharePoint 2010 RC. At the moment of this posting SharePoint 2010 RC is only available to selected partners.

The solution or so I thought was to revert back to:

  • .Net Framework 4 Extended Beta 2
  • .Net Framework 4 Client Profile Beta 2
  • Visual Studio 2010 Beta 2
  •  

    After reverting completely to a complete set of Visual Studio and .Net Framework Beta 2, was still receiving errors.

    That’s the price you pay for being on the bleeding edge, right?

    It has been a frustrating experience, but in the end I found a solution.

    Will post it on soon; stay tuned!

    1 comment:

    1. Please post your solution ... thanks!!!

      ReplyDelete